Need to upgrade docker package to 17.06.0+

冷猫 18天前 ⋅ 32 阅读

安装harbor时出现Need to upgrade docker package to 17.06.0+由于docker版本过低,记录解决方案

[root@localhost harbor]# ./install.sh 

[Step 0]: checking if docker is installed ...

Note: docker version: 1.13.1
✖ Need to upgrade docker package to 17.06.0+.
[root@localhost harbor]# docker version
Client:
 Version:         1.13.1
 API version:     1.26
 Package version: docker-1.13.1-209.git7d71120.el7.centos.x86_64
 Go version:      go1.10.3
 Git commit:      7d71120/1.13.1
 Built:           Wed Mar  2 15:25:43 2022
 OS/Arch:         linux/amd64

查看docker版本

rpm -qa | grep

删除低版本的docker安装包

yum remove docker-1.13.1-209.git7d71120.el7.centos.x86_64 docker-client-1.13.1-209.git7d71120.el7.centos.x86_64 docker-common-1.13.1-209.git7d71120.el7.centos.x86_64

升级docker

curl -fsSL https://get.docker.com/ | sh

重启docker,设置开机自启

systemctl restart docker
systemctl enable docker

全部评论: 0

    我有话说: